ever worked on Vista x64?

Oct 15, 2009 at 11:31 AM

i just tried to install the Beta 2 on a Vista x64 box. no luck. can't connect to 40500. don't know what's going wrong here.
for me it looks like it can't run on x64. but i have no clue what's going wrong. just installed a fresh Vista x86 and everything is fine.
even connection the sink on 40400 is working.

looks like a major problem on x64. interesting part is that my Win7 build without the EPG stuff is running on x86 and x64. i suppose
that refering the EPG DLL's depends on  the DLL build type. i found some information about MSAS and problems using it with x86
DLL's on a x64 system. but information and documentation is quite sparse at this point.

but it's hard to find what happens on a x64 installation without any information. can't see any debug log or error messages.
looks like the plugin simply isn't loaded. i have no idea why. any pointers?

Oct 15, 2009 at 11:46 AM
Edited Oct 15, 2009 at 11:47 AM

looks like a problem with the installer on x64. the plugin isn't registered on the x64 Vista. but the installer is returning no error.
for my Win7 setup i used WiX and not the Visual Studio Setup project. WiX is proposed all over the play in conjunction with installing
plugins for MC. i'll try to build a setup that's working on Vista x86 and x64.

any doubts about switching the installer to WiX?

Oct 15, 2009 at 11:57 AM

it's a installer fault.


Oct 22, 2009 at 10:21 PM

I had posted questions on this subject awhile back but no one responded with an answer until your post here.  I am beginning to hate my choice of operating systems because of this.

I have no ability to fix this issue since I do not know how to write or modify this code, unfortunately.  If you or anyone else can figure this issue out, I would love to know about it.  I am trying to write an interface for AMX automation.  At least I know I'm not crazy and that someone else has had the same issue.  Thanks for the info!

Oct 23, 2009 at 7:43 AM

there are a few quirks with x64. as you might have noticed i'm working on these problems. :) for now everything looks fine, except the button commands. there is another problem with the native API calls. everything else should be fine. i'll try to update the code this weekend and upload a 99% working version for x64. don't worry about your choice. hopefully we'll get full support for everything without problems on  x64. because it's the future. but as you can see sometime it's hard to get everything up and running in both worlds. so stay tuned. :)

Oct 23, 2009 at 2:07 PM

pantarhei, you are my hero!

Nov 6, 2009 at 10:58 PM

Any luck getting VMC to work on x64?

Nov 7, 2009 at 10:08 AM

At the moment i'm only working on the Win 7 problems. I'm using the 6.0 SDK. So my installer/plugin can't run on Vista. but i hope change it, cause there are no
6.0 only functions used. it should be possible to create an installer that is ok for Vista and Win 7 x64.

Nov 21, 2009 at 1:33 PM

Hi, would really appreciate if you could post a build of the version with the x64 installer. I don't have the ability to build it from source myself.



Nov 21, 2009 at 7:19 PM

it's available here: http://vmccontroller.codeplex.com/Release/ProjectReleases.aspx?ReleaseId=34386

keep in mind. it's Windows 7 only, no EPG and the key commands still aren't availbale . :(

Jan 15, 2010 at 3:30 PM

Please add me to the list of Vista x64 users that really, really wants this program to work.  Anyone found a workaround that gets us up and running?

Jan 15, 2010 at 9:05 PM

Adding a post so I can get an email notification if there are any replies.  Please ignore.

Jan 23, 2010 at 7:17 AM

I'd also like to use this software with Vista x64 Home Premium, Media Center and mControl to trigger events on my ISY99 home automation controller.

Feb 1, 2010 at 10:23 PM

I'm gonna just throw this out there, but it seems like the best fix for this (at least for the people who are stuck on Vista 64 with no ability to help themselves) is to upgrade.  Windows 7 is the future and it doesn't seem likely that anyone on this board would be willing to take their valuable time to work backwards.  I have to admit, it's the absolute right thing.  From my perspective, there's no way in hell that I would code my AMX systems backwards to fit old Axcess systems.

There are plenty of solutions available for Windows 7 to make this work, so I am just gonna bite the $79 upgrade bullet and move forward.  After all this isn't the only program that I am dying to get my hands on that skips over Vista and works with 7.  Big thanks to Pantarhei and others who have looked into this.

Mar 6, 2010 at 9:23 PM

Hi I am stuck on Vista64 for all of the other software I installed as well.  Is there any solution you can describe for those of us who want to use this?

Mar 6, 2010 at 9:41 PM

Adding a post for an email reply as well.  Thank you.

Mar 6, 2010 at 10:53 PM

Would it be possible for you to list the registry edits we need to make in the appropriate locations?  It would allow for a manual work around for us Vista 64 users.

Thanks again,

May 18, 2010 at 7:47 PM
The project im currently working on is using Windows 7 x64 and the play, pause, stop, ect.... commands don't work. anyone have a fix for this yet????
May 18, 2010 at 9:10 PM
Edited May 18, 2010 at 10:34 PM
Yes, but the build has not been released yet. If you are able to add the code and compile it I will send you the code. I am working on adding all the patches and some fixes to the Win7 x64 branch should have a new installer out soon.
May 18, 2010 at 11:09 PM
I would love it? Do you have instructions on how to add and compile. I don't mind trying myself. Thank you

On May 18, 2010, at 1:10 PM, "sickkick" <notifications@codeplex.com> wrote:

From: sickkick

Yes, but the build has not been released yet. If you are able to add the code and compile it I will send you the code.
May 25, 2010 at 10:17 PM
Edited May 25, 2010 at 10:51 PM

Check the downloads I just released the Win 7 64 bit version fix and the 32 bit(Has not been tested).

Jul 2, 2010 at 9:56 PM

I tried installing 46033 on windows 7 32bit and it gave an error the first time I ran media center it saying that it could not load.  I tried rebooting and reinstalling.  I don't get the error anymore when I start media center , but I am not able to connect via http.  I have not tried using telnet.


On win7 64bit it works for me, though I can't figure out how to queue albums and songs.  (playing an artist I can do)

I don't know if that's because of a bug, or because I don't know the correct method.  I can't find any examples of playing or queuing  albums or songs.

Jul 27, 2010 at 6:02 PM
Edited Aug 2, 2010 at 7:51 PM

The Vista 64bit, using from the sources I downloaded (47386), was not working because of the installer (via Visual Studio 2008) puts the registration of the keys in the Wow6432Node (for compatibility with x86), but Media Center X64 looks in the native registry keys, so the addin does not start.

I tried to set platform in VS2008 to x64, but I got other errors (not solved yet).

I made a workaround for this for the vmccontroller addin (probably the same to do for the state-module).

The workaround gives still not a fully functioning addin, because the SetForeGroundWindow in the SendKeys is not working (I believe changed someware in the life of Windows, but i am not sure). So several buttons are not working.

These settings has to be added.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Extensibility\Applications\{4e922cee-e302-11db-9ecb-3d7656d89593}]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Extensibility\Categories\Background\{5bf9f966-e302-11db-b831-747656d89593}]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Media Center\Extensibility\Entry Points\{5bf9f966-e302-11db-b831-747656d89593}]


Jul 28, 2010 at 5:14 PM
OK, it sounds like you can get limited control on Vista x64 (missing most of the main button commands) by adding this registry key. That's better than nothing I guess, but you mention using version 47386. Where can I find the installer for this version? Is this an installer for Win7x64 ?
Jul 28, 2010 at 8:07 PM

I Downnloaded the source and compiled it with Visual Studio 2008. It makes a setup.exe which uses the Windows Installer to install it on the target machine.

 There is not a downloadable setup (yet) on codeplex. I am not experienced with codeplex and can not give (much) support.

I am testing with the not-working buttons in Vista-X64. If i have a reasonable working version, i will try to put it on codeplex. If it can be with hints like my previous, I will do that (too).

The settings in my previous post will work also for other versions (I did not fully test that). 

Jul 28, 2010 at 8:33 PM
OK.. I took a stab at compiling myself with 2008 express, but there were many errors. If you have a working installer, there are many places that it could be hosted other than codeplex. I don't know much about codeplex either, but if you want I can host it on my website and then you could send link to one of the developpers to include on this site. If I can use it with another version, then which one should I use for Vistax64? the version made for Win7x64 found here: http://vmccontroller.codeplex.com/releases/view/45909 ?
Aug 23, 2010 at 8:36 PM

If you're still having issues with getting the commands to work properly then I have managed to fix it in my code. There are a couple of changes that need to take place:

1) Remove the 'size' attribute on the INPUT type.

2) Create a new INPUT64 struct that has FieldOffset(8) (instead of 4)

3) - the most random one: make sure there is a MOUSEINPUT struct too, and include that in the INPUT64 (again with FieldOffset(8) attribute).

In the code where you instantiate the INPUT object, have something like this:

if (IntPtr.Size == 8)

// Create INPUT64 and send this type

else if (IntPtr.Size == 4)

// Create INPUT and send this type.


The keystrokes now work on my 64bit machine. Hope this helps...