mControl Integration

Jul 18, 2008 at 5:45 AM
I am trying to integrate this with mControl.  Everything works fine on the console, but not luck with the extenders.

The extender will close out of Media Center and then go back in every 5 or so minutes.  Any ideas?

From the mControl log files:

2008-07-17 21:41:44.832 00:31:06.7604522 (004) X0 EAWmcControllerAdapter - EAWmcController: Exception in socket operation.
2008-07-17 21:41:44.832 00:31:06.7604522 (004) X1   System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.1.146:40401
2008-07-17 21:41:44.832 00:31:06.7604522 (004) X2    at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
2008-07-17 21:41:44.832 00:31:06.7604522 (004) X3    at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
2008-07-17 21:41:44.832 00:31:06.7604522 (004) X4    at System.Net.Sockets.TcpClient.Connect(IPEndPoint remoteEP)
2008-07-17 21:41:44.832 00:31:06.7604522 (004) X5    at EmbeddedAutomation.mServer.CommLib.ClientSocket.Connect()
2008-07-17 21:41:44.832 00:31:06.7604522 (004) X6    at EmbeddedAutomation.mServer.CommLib.TcpIpSocket.Open()
2008-07-17 21:41:44.832 00:31:06.7604716 (004) D0 EAWmcControllerAdapter - EAWmcController: using port [192.168.1.146:40401]
2008-07-17 21:41:44.832 00:31:06.7604757 (004) D0 EAWmcControllerAdapter - EAWmcController can not open port [192.168.1.146:40401]