switching channels with Windows 7

Jun 8, 2010 at 12:54 PM
Hi all, I have tried out this really helpful tool but I am facing a little problem: With the latest version for Windows 7, the commands "button-ch-minus" and "button-ch-plus" seem to be broken - when I'm using them, I only get the task bar icon of WMC flashing but the channels do not change. With the previous version for Windows 7, this worked. My 2 questions: - Does anybody know why these commands do not work in the latest Win7 release or what I could do to make them work? - I want to play around with the code to see if I can get TV information out of WMC, like the channel list or the current playing channel - Does anybody know what is the source of the first Win7 release (http://vmccontroller.codeplex.com/releases/view/34386)? I want to work on that because the newer release - as I mentioned above - does not work on my machine... Kind regards drakey2k
Developer
Jun 8, 2010 at 3:15 PM
Edited Jun 8, 2010 at 3:20 PM

The last release of Win7 most of the button commands were broken in the x64 version i am not sure if they were broken in the x86 version if they were working in x86 version then the fix should be simple. What version of Win7 are running?

To my knowledge EPG(cable tuner) part of Win7 has a lot of issues and has been disabled in the source. 

 

Jun 8, 2010 at 3:41 PM
I'm running Windows 7 Professional x86... What I am wondering is that with the older Win7 release, the switching of channels worked, but with the current Win7 version it doesn't.
Developer
Jun 8, 2010 at 3:57 PM

Were the rest of the button commands working before?

Jun 9, 2010 at 12:42 PM
Some of them were working, some of them not... Some examples for buttons that work in the first Win7 release: button-left button-right button-down button-down button-ok button-ch-minus button-ch-plus Some examples of buttons that dont work in the first Win7 release: button-play button-pause button-stop I am using only some of the buttons. With the latest Win7 release, I noticed, that button-ch-minus and button-ch-plus do not work any longer....